Posted By

raulaso15 on 09/24/18


Tagged

21 juego


Versions (?)

21 - bla


 / Published in: Pseudocode
 

Es un pequeño juego de 21 escrito en pseudo codigo con el software pseint.

  1. subproceso print_c (t,c_1,c_2,c_3,c_4,c_5,c_6,c_7,c_8,c_9,c_10,c_m)//valor actual de las cartas,c_m <- cartas que debe mostrar
  2. definir i,j,x,n_cart,cartas_en_mesa,carta_1,carta_2,carta_3,carta_4,carta_5,carta_6,carta_7,carta_8,carta_9,carta_10 como entero;
  3.  
  4. definir cartas como caracter;
  5. definir a,b,c,d,e,f,g,n,reng Como Caracter;
  6. dimension reng[4,5];
  7. dimension cartas[4,50];
  8.  
  9.  
  10. cartas_en_mesa<-c_m;
  11. n_cart<-(5*cartas_en_mesa)-1;
  12. x<-0;
  13. n<-"?";//son los caracteres que forman las figuras de las cartas
  14. a<-"|";
  15. b<-"_";
  16. c<-"|";
  17. d<-"|";
  18. e<-"";
  19. f<-" ";
  20. g<-"_";
  21.  
  22. reng[0,0]<-f;
  23. reng[0,1]<-b;
  24. reng[0,2]<-b;
  25. reng[0,3]<-b;
  26. reng[0,4]<-f;
  27.  
  28. reng[1,0]<-a;
  29. reng[1,1]<-f;
  30. reng[1,2]<-f;
  31. reng[1,3]<-f;
  32. reng[1,4]<-a;
  33.  
  34. reng[2,0]<-a;
  35. reng[2,1]<-f;
  36. reng[2,2]<-n;
  37. reng[2,3]<-f;
  38. reng[2,4]<-a;
  39.  
  40. reng[3,0]<-c;
  41. reng[3,1]<-g;
  42. reng[3,2]<-b;
  43. reng[3,3]<-g;
  44. reng[3,4]<-d;
  45.  
  46. para i <-0 hasta 3 Hacer//genera un arreglo que muestra 10 cartas en 4 renglones cada una, una al lado de la otra
  47. para j<-0 hasta 49 Hacer
  48. si x<5 entonces
  49. cartas[i,j]<-reng[i,x];
  50. x<-x+1;
  51. FinSi
  52. si x>4 entonces
  53. x<-0;
  54. FinSi
  55.  
  56. FinPara
  57. FinPara
  58.  
  59. carta_1<-c_1;
  60. carta_2<-c_2;
  61. carta_3<-c_3;
  62. carta_4<-c_4;
  63. carta_5<-c_5;
  64. carta_6<-c_6;
  65. carta_7<-c_7;
  66. carta_8<-c_8;
  67. carta_9<-c_9;
  68. carta_10<-c_10;
  69.  
  70.  
  71. si carta_1>9 Entonces//si el numero tiene 2 cifras ajusta el espacio para que no se deforme la carta
  72. cartas[2,1]<-e;
  73. FinSi
  74. si carta_2>9 Entonces
  75. cartas[2,6]<-e;
  76. FinSi
  77. si carta_3>9 entonces
  78. cartas[2,11]<-e;
  79. FinSi
  80. si carta_4>9 Entonces
  81. cartas[2,16]<-e;
  82. FinSi
  83. si carta_5>9 Entonces
  84. cartas[2,21]<-e;
  85. FinSi
  86. si carta_6>9 entonces
  87. cartas[2,26]<-e;
  88. FinSi
  89. si carta_7>9 Entonces
  90. cartas[2,31]<-e;
  91. FinSi
  92. si carta_8>9 Entonces
  93. cartas[2,36]<-e;
  94. FinSi
  95. si carta_9>9 entonces
  96. cartas[2,41]<-e;
  97. FinSi
  98. si carta_10>9 Entonces
  99. cartas[2,46]<-e;
  100. FinSi
  101. cartas[2,2]<-CONVERTIRATEXTO(carta_1);//guartda el valor en el lugar que correspnde para que se imprima en el centro de la carta
  102. cartas[2,7]<-ConvertirATexto(carta_2);
  103. cartas[2,12]<-CONVERTIRATEXTO(carta_3);
  104. cartas[2,17]<-CONVERTIRATEXTO(carta_4);
  105. cartas[2,22]<-CONVERTIRATEXTO(carta_5);
  106. cartas[2,27]<-CONVERTIRATEXTO(carta_6);
  107. cartas[2,32]<-CONVERTIRATEXTO(carta_7);
  108. cartas[2,37]<-ConvertirATexto(carta_8);
  109. cartas[2,42]<-CONVERTIRATEXTO(carta_9);
  110. cartas[2,47]<-CONVERTIRATEXTO(carta_10);
  111.  
  112. si cartas_en_mesa<3 y t=0 entonces//hace que en la primer mano, el valor de la segunda carta de la mesa no sea visible
  113. cartas[2,7]<-n;
  114. si carta_2>9 Entonces
  115. cartas[2,6]<-f;
  116. FinSi
  117. FinSi
  118.  
  119. para i <-0 hasta 3 Hacer//imprime los cuatro renglones de las cartas
  120. para j <-0 hasta n_cart Hacer//n_cart indica el numero de cartas que debe mostrar
  121. si j=0 entonces
  122. escribir " ",cartas[i,j],sin saltar;//deja un espacio antes de la primer carta
  123. sino
  124. si (1+j) mod 5 =0 entonces
  125. escribir cartas[i,j]," ",sin saltar;//deja un espacio entre las cartas
  126.  
  127. sino
  128. escribir cartas[i,j],sin saltar;
  129. finsi
  130.  
  131. FinSi
  132. FinPara
  133. escribir "";
  134. FinPara
  135. Escribir "";
  136. Escribir "";
  137.  
  138. FinsubProceso
  139.  
  140. subproceso espacio(num)//deja "num" lineas en blanco
  141. definir i como entero;
  142. para i<-1 hasta num hacer
  143. escribir "";
  144. FinPara
  145. FinSubProceso
  146.  
  147. subproceso Linea(num)//imprime una linea separadora de largo "num"
  148. definir i como entero;
  149. para i<-1 hasta num hacer
  150. escribir "__",sinsaltar;
  151. FinPara
  152. escribir "";
  153. FinSubProceso
  154.  
  155. subproceso carta<- cart (jugadas,num)//elije la carta num de las 20 repartidas al azar
  156. definir carta Como Entero;
  157. carta<-jugadas[num];
  158. FinSubProceso
  159.  
  160. SubProceso reglas()//si el ususario pone si, imprime las reglas del juego
  161. definir resp como caracter;
  162. escribir " Si desea leer las reglas del juego escriba si, para";
  163. escribir " comenzar el juego presione enter.";
  164. leer resp;
  165. si resp="si" Entonces
  166. Borrar Pantalla;
  167. espacio(1);
  168. escribir "Reglas del juego: ";
  169. espacio(1);
  170. escribir"El objetivo del juego es sumar 21 puntos o llegar los mas cerca posible sin pasarse";
  171. escribir"En caso de que los jugadores no lleguen a 21, quien quede mas cerca gana";
  172. espacio(1);
  173. escribir"La mesa reparte inicialmente 2 cartas a los jugadores y 2 para la mesa, ";
  174. escribir"la segunda carta de la mesa permanece oculta hasta que el jugador termine su mano";
  175. escribir"una vez repartidas las cartas iniciales, el jugador podra pedir ";
  176. escribir"carta, hasta que se plante, o se pase de 21";
  177. espacio(1);
  178. escribir"Puntajes: Las cartas mayores a 9 suman 10 puntos, los ases suman 1 punto u 11, segun convenga, el resto de las cartas ";
  179. escribir"suman su valor numerico";
  180. Escribir "Si el jugador obtiene en las dos primeras cartas la suma de 21 se considera Black Jack automaticamente gana la partida";
  181. espacio(1);
  182. escribir"Apuestas: Las apuesas se realizan antes de repartir las cartas";
  183. espacio(1);
  184. escribir"Pago: A los jugadores que hacen Black Jack se les paga 3 a 1 su apuesta, a los que ganen ";
  185. escribir"en el transcurso de la partida se les paga el mismo valor de la apuesta";
  186. escribir"En caso de empate, se devuelve el valor de la apuesta";
  187. espacio(1);
  188. escribir" Para comenzar el juego presione enter.";
  189. Esperar Tecla;
  190. FinSi
  191. finsubproceso
  192.  
  193. Proceso BJ
  194. reglas();
  195. Limpiar Pantalla;
  196. definir finjuego,se_planta,b_j,w_mesa,w_jug,empate, esEntero,sin_dinero como logico;
  197. definir car_1,car_2,car_3,car_4,car_5,car_6,car_7,car_8,car_9,car_10,cartas_jug,mano,cartas_mesa,chang,chang_m,var como entero;
  198. definir baraja,jugadas,i,j,x,n,a,b,c,d,e,f,caja,apuesta,puntos_j,puntos_m,cont,cont_m,n_juegos como entero;
  199. definir seguir_jugando,resp,exclamacion,mens_1, mens_2,mens_3, mens_4, mens_5,mens_6,mens_7,mens_8,mens_9,mens_10,mens_11,mens_12,mens_13,mens_14,mens_15,mens_16,opc como caracter;
  200. Definir apuest, vx Como Cadena;
  201. seguir_jugando<-"si";//solo para inicializar la variable
  202. sin_dinero<-falso;
  203.  
  204.  
  205.  
  206. mens_1<-" Hola, bienbenido a 21, Suerte!!";
  207. mens_2<-" Cuanto quieres apostar en esta mano? ";
  208. mens_3<-" Lamentablemente no dispones de tanto dinero, debes apostar menos de: ";
  209. mens_4<-" Tus cartas son: ";
  210. mens_5<- " La primer carta de la mesa es: ";
  211. mens_6<-" Para pedir otra carta responder si, o presiona Enter para plantarse";
  212. mens_7<-" Tu apuesta actual es de: ";
  213. mens_8<-" Lamentablemente en esta mano has perdido :(";
  214. mens_9<-" Felicidades, le ganaste a la mesa!!!!";
  215. mens_10<-" El valor de la apuesta debe ser un Numero mayor que cero y menor que ";
  216. mens_11<-" Para que el juego tenga un poco de gracia deberias apostar algo mas ";
  217. mens_12<-" Felicidades, has sacado 21 en la primer mano y le ganaste a la mesa";
  218. mens_13<-" En este caso el valor de tu apuesta se triplica, has ganado: $";
  219. mens_14<-" ups perdiste, te has pasado de 21 ";
  220. mens_15<-" Has ganado: $";
  221. mens_16<-" Esta mano ha terminado en empate, te devolvemos tu apuesta";
  222. caja<-1500;
  223. apuesta<-1;
  224. exclamacion<-"!!!";
  225. dimension jugadas[20];//aca se guardan las 20 cartas al azar
  226. dimension baraja[48];//maso de cartas
  227. n<-1;
  228. x<-0;
  229. n_juegos<-0;
  230.  
  231. mientras seguir_jugando<>"no" y sin_dinero=falso Hacer//mientras el jugador quiera seguir y tenga aun dinero
  232.  
  233. Borrar Pantalla;
  234. finjuego <- falso;
  235. se_planta<-falso;
  236. //se vuelven a iniciar algunas variables, menos caja
  237. puntos_j<-0;
  238. puntos_m<-0;
  239. w_mesa<-falso;
  240. w_jug<-falso;
  241. empate<-falso;
  242. b_j<-falso;
  243. cont<-1;
  244. cont_m<-12;
  245. chang<-0;
  246. chang_m<-0;
  247.  
  248. x<-0;
  249. si n_juegos=0 o n_juegos mod 2 =0 Entonces//cada 2 jugads se vuelve el maso a su estado inicial
  250. para i<-0 hasta 3 hacer //una vez por cada palo
  251. n<-1;//primera carta de cada palo
  252. para j<-0 hasta 11 hacer
  253. baraja[x]<-n;
  254. x<-x+1;//x recorre las 48 cartas del maso
  255. n<-n+1;
  256. FinPara//guarda en el maso 12 cartas x 4 palos
  257.  
  258. FinPara
  259. FinSi
  260. i<-0;
  261. mientras i<20 hacer// reparte 20 cartas al azar de 48 disponibles en el maso
  262. x<-azar(48);
  263. si baraja[x]<> 0 entonces
  264. jugadas[i]<-baraja[x];//guarda las 20 cartas en jugadas
  265. baraja[x]<-0;//evita que se repitan las cartas del maso
  266. i<-i+1;
  267. FinSi
  268.  
  269. Finmientras
  270.  
  271. n_juegos<-n_juegos+1;//contador de juegos, se vuelve a cear el maso de cartas cada 2 juegos
  272.  
  273. escribir mens_1, exclamacion;
  274.  
  275. espacio(1);
  276.  
  277. escribir " Dinero disponible: ",caja;
  278.  
  279. espacio(1);
  280.  
  281.  
  282. repetir
  283. Escribir mens_2;
  284. Leer apuest;
  285.  
  286. // Validar si es un numero
  287. esEntero<- Verdadero;
  288. // 123
  289. n<-LONGITUD(apuest);
  290. i<-0;
  291. Mientras ((i < n ) Y (esEntero)) Hacer
  292. vx<- SUBCADENA(apuest, i, i);
  293.  
  294. esEntero<- (vx = "0") O (vx = "1") O (vx = "2") O (vx = "3") O (vx = "4") O (vx = "5") O (vx = "6") O (vx = "7") O (vx = "8") O (vx = "9") O (vx = "-");
  295. i<-i+1;
  296. FinMientras
  297.  
  298. Si no(esEntero) entonces
  299. Borrar Pantalla;
  300. Escribir " Debe ingresar un numero: ";
  301. FinSi
  302.  
  303. si esEntero entonces
  304. apuesta<-convertiranumero(apuest);
  305. FinSi
  306.  
  307.  
  308. si apuesta> caja entonces
  309. Borrar Pantalla;
  310. espacio(1);
  311. escribir mens_3,caja,exclamacion;
  312. espacio(1);
  313. esperar 2 segundos;
  314. esEntero<-falso;
  315. finsi
  316.  
  317. si apuesta=0 Entonces
  318. escribir mens_11;
  319. esEntero<-falso;
  320. FinSi
  321.  
  322.  
  323.  
  324. Hasta Que (esEntero)
  325.  
  326. Borrar Pantalla;
  327. caja<-caja-apuesta;
  328. escribir " Dinero disponible: ",caja;
  329.  
  330. escribir mens_7,apuesta;
  331. espacio(1);
  332.  
  333. cartas_jug<-2;//numero de cartas que se muetran en la primer mano al jugador
  334. cartas_mesa<-2;//numero de cartas que se muestran en la primer mano a la mesa
  335. mano<-0;
  336.  
  337. mientras finjuego = falso hacer//desarrollo del juego
  338. Borrar Pantalla;
  339. escribir " Dinero disponible: ",caja;
  340.  
  341. escribir mens_7,apuesta;
  342. espacio(1);
  343. si mano=0 y cartas_jug<3 Entonces //acumula los puntos de la primer carta de la mesa
  344. si cart(jugadas,11) <>1 y cart(jugadas,11) <10 Entonces//si la carta es ditinta de uno y menor a diez
  345. puntos_m<-puntos_m+cart(jugadas,11);//suma el valor de la carta
  346. SiNo
  347. si cart(jugadas,11)=1 Entonces//si la primer carta es 1 vale 11
  348. puntos_m<-puntos_m+11;
  349. chang_m<-chang_m+1;//cambia la variable que permite volver el 11 a 1 si es conveniente
  350.  
  351. sino
  352. si cart(jugadas,11)>9 Entonces//si vale 10 o mas se suman 10
  353. puntos_m<-puntos_m+10;
  354. finsi
  355. FinSi
  356. FinSi
  357.  
  358. FinSi
  359. car_1<-cart(jugadas,11);//almacena en la variable car_n el valor de la carta que le toco a la mesa para imprimirla
  360. car_2<-cart(jugadas,12);//para la mesa se sacaron las cartas del 10 al 19
  361. car_3<-cart(jugadas,13);
  362. car_4<-cart(jugadas,14);
  363. car_5<-cart(jugadas,15);
  364. car_6<-cart(jugadas,16);
  365. car_7<-cart(jugadas,17);
  366. car_8<-cart(jugadas,18);
  367. car_9<-cart(jugadas,19);
  368. car_10<-cart(jugadas,10);
  369.  
  370.  
  371. si se_planta=verdadero Entonces//se ejecuta luego de la mano del jugador
  372. mano<-mano+1;
  373. si cart(jugadas,12)=1 Entonces//se evalua el valor de la segunda carta de la mesa
  374. si puntos_m<11 Entonces
  375. puntos_m<-puntos_m+11;
  376. chang_m<-chang_m+1;
  377. SiNo
  378. puntos_m<-puntos_m+1;
  379. FinSi
  380. SiNo
  381. si cart(jugadas,12)<10 Entonces
  382. puntos_m<-puntos_m+cart(jugadas,12);
  383. SiNo
  384. puntos_m<-puntos_m+10;
  385. FinSi
  386. FinSi
  387.  
  388.  
  389. si puntos_m>21 y chang_m<>0 Entonces//si se pasa de 21 y hay un 1 con valor 11, lo vuelve a uno
  390. puntos_m<-puntos_m-10;
  391. chang_m<-chang_m-1;
  392. FinSi
  393.  
  394. FinSi
  395. si mano>1 y se_planta=Verdadero Entonces//luego de la mano del jugador y de descubrir la segunda carta de la mesa
  396. i<-13; //a partir de la tercer carta de la mesa
  397. mientras puntos_m<=17 y puntos_m<=puntos_j Hacer//la mesa deja de sacar cartas cuando llega a 17 o si supera al jugador
  398.  
  399.  
  400. si cart(jugadas,i)=1 Entonces
  401. si puntos_m<11 Entonces
  402. puntos_m<-puntos_m+10;
  403. chang_m<-chang_m+1;
  404. SiNo
  405. puntos_m<-puntos_m+1;
  406. FinSi
  407. SiNo
  408. si cart(jugadas,i)<10 Entonces
  409. puntos_m<-puntos_m+cart(jugadas,i);
  410. SiNo
  411. puntos_m<-puntos_m+10;
  412. FinSi
  413. FinSi
  414.  
  415.  
  416. si puntos_m>21 y chang_m<>0 Entonces
  417. puntos_m<-puntos_m-10;
  418. chang_m<-chang_m-1;
  419. FinSi
  420. cartas_mesa<-cartas_mesa+1;//aumenta la cantidad de cartas a mostrar para mesa
  421.  
  422. i<-i+1;//pasa a la siguiente carta
  423.  
  424.  
  425.  
  426.  
  427. FinMientras
  428. finjuego<-verdadero;//cuando alcanza 17 puntos o mas termina el juego
  429. FinSi
  430.  
  431. escribir " Las cartas de la mesa son: ";
  432.  
  433. print_c(mano,car_1,car_2,car_3,car_4,car_5,car_6,car_7,car_8,car_9,car_10,cartas_mesa);
  434. escribir " Las catras de la mesa suman: ", puntos_m, " puntos";
  435. Linea(28);
  436. espacio(1);
  437.  
  438. car_1<-cart(jugadas,1);//valor de las 10 cartas del jugador
  439. car_2<-cart(jugadas,2);//son las cartas del 0 al 9 de las seleccionadas al azar
  440. car_3<-cart(jugadas,3);
  441. car_4<-cart(jugadas,4);
  442. car_5<-cart(jugadas,5);
  443. car_6<-cart(jugadas,6);
  444. car_7<-cart(jugadas,7);
  445. car_8<-cart(jugadas,8);
  446. car_9<-cart(jugadas,9);
  447. car_10<-cart(jugadas,0);
  448.  
  449.  
  450. espacio(1);
  451. escribir " Tus cartas son: ";
  452. espacio(1);
  453. si se_planta=falso Entonces//mientras pida mas cartas
  454. para i<-cont hasta cartas_jug Hacer//cont inicial vale uno, accion para la carta uno
  455. si puntos_j <11 y cart(jugadas,i)=1 Entonces
  456. var <-cart(jugadas,i);//si sale un uno y es conveniente cambia a 11
  457. var<-11;
  458. chang<-chang+1;//esta variable indica que hay un uno que vale 11 en caso de que se pase se puede restar 10
  459. puntos_j <- puntos_j+var;
  460.  
  461. sino
  462. si puntos_j >10 y cart(jugadas,i)=1 Entonces//si tiene 11 pntos o mas el uno vale uno
  463. puntos_j<-puntos_j+cart(jugadas,i);
  464. finsi
  465. FinSi
  466. si cart(jugadas,i)>9 entonces //si la carta es 10 o mas,se suman 10 puntos
  467. puntos_j <-puntos_j+10;
  468. SiNo
  469. si cart(jugadas,i)<>1 entonces//si no es mayor a 9 y es distinta de uno, se suma el valor de la carta
  470. puntos_j<-puntos_j+cart(jugadas,i);
  471. finsi
  472. FinSi
  473. si puntos_j>21 y chang>0 Entonces//si se paso de 21 y hay algun 1 con valor 11, se restan 10(el uno vuelve a valer uno)
  474. puntos_j<-puntos_j-10;
  475. chang<-chang-1;
  476. FinSi
  477. cont<-cont+1;
  478. FinPara
  479.  
  480. FinSi
  481.  
  482.  
  483. print_c(1,car_1,car_2,car_3,car_4,car_5,car_6,car_7,car_8,car_9,car_10,cartas_jug);//imprime las cartas del jugador
  484.  
  485. escribir " Tus cartas suman: ",puntos_j," puntos.";
  486. opc<-"fin";//solo para inicializar la variable
  487. si cartas_jug=2 y puntos_j =21 y puntos_m<21 y se_planta=falso Entonces//si es la primer mano y obtinene 21 gana
  488. caja<- caja+apuesta*3;
  489. Escribir mens_12;
  490. escribir mens_13,apuesta*3;
  491. escribir " Dinero disponible: ",caja;
  492. finjuego<-Verdadero;//termina el juego
  493. se_planta<-falso;
  494. b_j<-Verdadero;//variable para no volver a sumar la caja terminado el juego
  495. FinSi
  496. si puntos_j<21 y se_planta= falso entonces//mientras no se pase de 21 y pida otra carta
  497. escribir mens_6;
  498. leer opc;
  499. finsi
  500. si opc ="si" y puntos_j<21 Entonces//si piede mas cartas
  501. finjuego<-Falso;
  502. cartas_jug<-cartas_jug +1;//incementa l numero de cartas a mostrar para el jugador
  503.  
  504. FinSi
  505. si puntos_j<=21 y opc<>"si" Entonces//si no pide mas cartas y no se pasa de 21, se planta
  506. se_planta <- Verdadero;
  507.  
  508. FinSi
  509. si se_planta=verdadero entonces
  510. mano<-mano+1;//sale de la mano 0 para el jugador, la mesa ahora mostrara sus 2 cartas a la vista
  511. FinSi
  512. // Borrar Pantalla;
  513. si puntos_j>21 Entonces//si se pasa de 21 trmina el juego
  514. finjuego<-verdadero;
  515. FinSi
  516.  
  517. si caja=0 Entonces
  518. sin_dinero<-Verdadero;
  519. FinSi
  520.  
  521. FinMientras
  522.  
  523. espacio(2);
  524. linea(28);
  525.  
  526. si puntos_j>=22 Entonces//si el jugador se pasa de 21 gana la mesa
  527. w_mesa<-Verdadero;
  528. FinSi
  529. si puntos_j<=21 y b_j=falso Entonces//cuando no se paso y no tiene 21 en la primer mano(la apuesta se paga distinto)
  530. si puntos_j>puntos_m o puntos_m>=22 Entonces//si la mesa tine menos puntos, o si la mesa se pasa gana jugador
  531. w_jug<-Verdadero;
  532. SiNo
  533. si puntos_j=puntos_m Entonces//si no se pasa y empata con la mesa -empate
  534. empate<-verdadero;
  535. SiNo
  536. w_mesa<-Verdadero;//en otro caso gana la mesa
  537. FinSi
  538. FinSi
  539. FinSi
  540.  
  541. si empate Entonces
  542. escribir mens_16;
  543. caja<-caja+apuesta;
  544. sino
  545. si w_mesa Entonces
  546.  
  547. escribir mens_8;
  548. SiNo
  549. si b_j=falso entonces
  550. escribir mens_9;
  551.  
  552. escribir mens_15 ,apuesta;
  553. espacio(1);
  554. caja<-caja+(apuesta*2);
  555. finsi
  556. FinSi
  557. FinSi
  558. si caja>0 Entonces
  559. sin_dinero<-falso;
  560. FinSi
  561. si sin_dinero=falso Entonces
  562.  
  563. Linea(28);
  564. Escribir " Quieres seguir jugando?";
  565. espacio(1);
  566. escribir " Escriba no para salir, presione enter para seguir jugando";
  567. leer seguir_jugando;
  568. SiNo
  569. escribir " y te quedaste sin dinero";
  570. FinSi
  571. FinMientras
  572.  
  573. FinProceso

Report this snippet  

You need to login to post a comment.