Posted By

jicey on 12/12/14


Tagged

windevsqlhexecuterequetesql


Versions (?)

WINDEV - Exécution direct de requête via ODBC


 / Published in: W-Language
 

Passage direct d'une requête via une source de données ODBC

  1. sRemplcement est une chaîne
  2. sdReqSel est une Source de Données
  3. sReqSel est une chaîne = "SELECT COUNT(*) AS NB " + ...
  4. "FROM ZPLATEFORMEENCOURS " + ...
  5. "WHERE PEC_PLATEFORME = '{NumPlateforme}'"
  6.  
  7. sReqSel = Remplace(sReqSel, "{NumPlateforme}", sRemplacement)
  8.  
  9. SI PAS HExécuteRequêteSQL(sdReqSel, ConnexionCegid, hRequêteSansCorrection, sReqSel) ALORS
  10. Erreur("Erreur lors de ...")
  11. Erreur(HErreurInfo())
  12. VersPressePapier(sReqSel)
  13. SINON
  14. HLitPremier(sdReqSel)
  15.  
  16. TANTQUE PAS HEnDehors(sdReqSel)
  17.  
  18. HLitSuivant(sdReqSel)
  19. FIN
  20. FIN
  21.  
  22. HFerme(sdReqSel)

Report this snippet  

You need to login to post a comment.