Posted By

josephknight on 07/05/10


Tagged

php wordpress security


Versions (?)

Who likes this?

1 person have marked this snippet as a favorite

artificialid


WordPress - remove version number from head


 / Published in: PHP
 

If your WordPress blog is outdated even by a few days and there's a security hole in your old version you could be seriously compromised without even knowing it. Trust me. This has happened to two of my clients and the fix is not easy. Usually, once compromised, you have to delete the blog and reinstall WordPress, then scour your theme and uploaded files before re-uploading to the server. Avoid this hassle (or worse damage to your blog) if you can.

  1. remove_action('wp_head', 'wp_generator');

Report this snippet  

You need to login to post a comment.